
Orchard Link Mapping Workshop
(QGIS Training) 

Contact

email: info@neetmaps.co.uk for technical support, bespoke mapping or
further information or visit www.neetmaps.co.uk
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1: Introduction to QGIS

What is QGIS?

QGIS is a user friendly Open Source Geographic Information System (GIS) licensed under
the GNU General Public License. QGIS is an official project of the Open Source 
Geospatial Foundation (OSGeo). It runs on Linux, Unix, Mac OSX, Windows and Android 
and supports numerous vector, raster, and database formats and functionalities. 

Source: http://www.qgis.org/en/site/about/index.html

QGIS will only develop further if it supported by you and the user community so 
remember to please donate to the project if you are able.

http://qgis.org/en/site/getinvolved/governance/sponsorship/sponsorship.html

In short, QGIS is great software to view, create, query and print geographic information – 
so let's make a start!

2: Installing QGIS

Make sure you have installed the latest version of QGIS on your computer from 

http://www.qgis.org/en/site/forusers/download.html

Select the appropriate operating system (Windows / Linux etc.) and click the relevant link
The QGIS Icon has recently changed to the one shown above. (These notes will continue 
to use the logo used in 2.18.6 and lower)

Once downloaded you should see a file similar to the one below.  Double click the file to 
install. 

Once installed you can start QGIS by clicking the icon on your desktop.
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When you click on the QGIS icon the default “project” is loaded and the QGIS Tips 
appear.  You can stop these appearing by clicking on the checkbox “I've had enough tips, 
don't show this on start up anymore!”

3: The QGIS user interface

(1) MENU BAR – provides access to all the functions and plugins

(2) TOOLBARS – provides a single click to common functions

(3) PANELS –  includes layer and overview panel plus others

(4) MAP CANVAS – provides a dynamic visualization of the active data layers

(5) STATUS BAR – provides information about the current project settings 

(Coordinates, Map Scale and Projection)
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4:  QGIS Configuration

QGIS is highly configurable through the Settings menu.  This is a quick-start version!

Options

Some basic options for QGIS can be selected using the Options menu.  These can be set 
under the Settings > Options menu.

General 

There are many settings in here but some of the more immediately useful ones are 

Icon Size sets the icon size. 32 point is good as it makes the icons very easy to read 
which is perfect for getting used to the interface.

Font changes the font family used and size of the text used for menus. 10 is a good size.

Hide splash screen at startup – does what it says on the tin!

CRS 

All maps (both digital and paper) are based on a coordinate reference system (CRS).  The 
CRS affects how layers are displayed on screen and different CRSs work in different parts 
of the globe.

If two layers use a different CRS then map objects may not line up properly and 
measurements may be incorrect.  You can check the CRS of a layer at any time by double 
clicking on it and checking the settings under the General options.

The most common CRS we will use today is British National Grid.  This can be set as a 
default by choosing the option below and choosing Select...

The easiest way to search for a specific CRS is using its unique EPSG code. The EPSG 
code for British National Grid is 27700. 
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5: Loading and Viewing Map Information

In this section we will look at loading different types of mapping, how to navigate around 
the map view and how to manage our map layers through zoom layering. We will save our 
work in a qgis project.  This section is best understood through exercises with which you 
can follow along.

Loading Map Layers

QGIS recognizes vector and raster layers as well as some custom layer types.

Base maps such as aerial photos are raster whereas point, line and polygon data is 
vector. 

Let's make a start by loading some data into QGIS.....

Data can be added in 2 ways, either via the Manage Layers toolbar shown below or by 
simply dragging and dropping into the Map View if you know what file types you want to 
show.

Exercise 5.1 Loading Raster Data

In the next example we are going to load some OS VectorMap District background 
mapping which has been downloaded from Ordnance Survey website.

OS VectorMap District is one of currently 12 different mapping products available as a download as OS 
OpenData which are free for public use under the terms of an OS OpenData licence.  

You must always use the following attribution statement to acknowledge the source of the information: 
Contains Ordnance Survey data © Crown copyright and database right [year] 

For more information on OS OpenData visit
http://www.ordnancesurvey.co.uk/business-and-government/licensing/using-creating-data-with-os-
products/os-opendata.html

or just “Google” OS OpenData!

Press the Add Raster Layer button on the Manage Layers toolbar and browse to 
the files you want to open.  

The files are in the “Training\MAPS\OS VMD Raster” folder.

We will load the tile SX85 which covers the Stoke Gabriel / Sharpham area

The file is in GeoTiff format which means that it has coordinates embedded in the file 
telling QGIS where to place it in the world.
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Dependent on how your copy of QGIS has been set-up you may be prompted for the CRS 
that you want to use.  Remember that we want to see the mapping in British National 
Grid (EPSG code 27700).

Another way to achieve the same result would have been to drag-and-drop the file into 
the map canvas.   Your layer panel should now look like this:

The layer panel allows you to rename, turn on and off map layers as well as group layers 
together and change the style and projection.  

If your map view is not showing any of the mapping then simply right-click on the layer 
above and choose Zoom to Layer

You should now see some mapping on your screen – albeit a bit grainy at the moment but 
we will improve this later.

Moving around the map

Before we go any further it is worth introducing the Map Navigation controls.  These are 
defined as follows:

Pan Map
Zoom to extents of 
selected layer 

Zoom in Zoom to selection

Zoom out
Go back to a previous 
view

Zoom to full extents
(all layers)

Move forward to a 
previous view

Touch Zoom and 
Pan
(touchscreens only)

Spend some time moving around the map using the tools above.  Remember to use the 
mouse wheel as well to zoom in or out.

Exercise 5.2  Adding some further Raster Data

In the next example we are going to load some OS OpenMap Local data has been 
downloaded from Ordnance Survey website.  The mapping is produced at a larger scale  
than the VectorMap District as you will see.
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Press the Add Raster Layer button on the Manage Layers toolbar and browse to the files 
you want to open.  

The file is in the “Training\MAPS\OS OpenMapLocal” folder.

Again, the files are in GeoTiff format so they should fit straight into the correct geographic 
place. (Remember Drag and Drop which is easier!)

Exercise 5.3 Creating a layer group

We will use the four OS Open Map Local tiles you have just loaded in this example.

You will notice that the layer control is starting to fill up with map layers.  The four OS 
OpenMap Local layers can be made more manageable by grouping them in a layer tree / 
folder as follows.

Highlight the four maps  SX85SE, SX85SW, SX85NE, SX85NW, right click and choose 
Group Selected from the menu that appears.

The text group1 will be shown in the layer control.  Give this a sensible name by right-
clicking and choosing Rename. Call the group OS_Local.

Exercise 5.4 Setting zoom scales for different map layers

Zoom scales can be used to turn map layers on or off dependent on the viewing scale.

Setting the zoom scale can be done either by right-clicking the layer name in the Layer 
control.  Set the zoom scales as follows:

Layer Name SX85 Minimum 1: 1,000,000 Maximum 1: 15,000
Layer Name OS_Local Minimum 1: 15,000 Maximum 1: 1

Note: Setting zoom scales for a layer group such as OS_Local above, requires you to 
double-click into the layer group and select all layers from inside it first.
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Exercise 5.5  Loading Vector data

In the next example we are going to load a vector map layer from Natural England.  

Natural England have made some of their data available for use in a similar way to 
Ordnance Survey. Make sure you check the specific terms of use before downloading 
and using them as some of the licences are slightly different which may mean a different 
copyright or it may mean that you can not use the data for commercial gain.  Data from 
Natural England are available in ArcGIS and MapInfo formats.

Press the  Add Vector Layer button on the Manage Layers toolbar and browse to 
the files you want to open. 

Again, like Raster files you can use drag and drop here as long as you know what file type 
you are using.  The file in this example is an ESRI shape file (*.shp)  called 
PHI_SX85.shp from in the “Training\MAPDATA\NaturalEngland” folder.  

If you choose not to drag and drop 
then you will need to complete the 
additional step below.  Keep the 
Source Type as File, the Encoding 
as System and Browse to the 
dataset you require.

Press Open when ready.

Exercise 5.6  Changing map styles

Lets have a look at our layers in the Layer panel.  It should look something like this:

You will notice that QGIS applies random styling to each vector layer as it gets loaded if no
styling files are supplied.  You can use the layer control to change the way the maps are 
styled as follows:

Double click the layer name in the Layer Manager. This will open up the Layer Properties
for that particular layer.  Each map layer has its own properties section.

Choose the style panel....

This is where you can unleash your creativity!  Its possible to set complex fill colours and 

9



outline styles as well as transparency settings for each layer.

You can also choose, amongst other options, to create a categorised map, based on 
values in the data that the layer may contain.  

Choose Categorised and then choose “Main Habit” from the drop down list.

Press Classify and OK

This will create a colour coded layer based on each Priority Habitat.

Now save the project by choosing Project > Saves As and
give the project a name.  QGIS will give the project a *.qgs
file extension.

Congratulations – you have now set up your first QGIS project!
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6: Plugins

Plugins are small programs for specific tasks written by the community.  Check out the 
website https://plugins.qgis.org/plugins/ for further details.

Some useful plugins include: 

go2streetview 

View Google Street View or Bing Bird's
Eye linked to the map.  

Mirror Map 

Add one or more linked map windows –
useful for comparing different map series.

QuickMapServices 

View OpenStreetMap, Google Maps, Bing Maps, 
MapQuest layers

Qgis2web

generates a web map from your current
QGIS project, either as OpenLayers3 or Leaflet. 

Zoom to Coordinates

Type in an x,y coordinate and zoom to the
location

Qgis2threejs 

Qgis2threejs plugin exports terrain data,
map canvas image and vector data to your web 
browser and displays it in 3d

Mask 

quickly transform a polygon selection into a
map masking layer or a region of interest 

TomBio tools

Aimed mainly at biological recorders, it
contains the OSGR tool for OS Map grids

Exercise 6.1 Load the QuickMapServices plugin

Choose Plugins > Manage and Install Plugins and type “quickmap” in the search box.

Select QuickMapServices and Install plugin. 

A new menu under web will appear. 

Choose Web > QuickMapServices and choose settings 

Select the More services tab

Select Get Contributed Pack (this will show more services like Google Maps)

You will now be able to load imagery from the Web menu from Google or Bing Satellite 
from the Web toolbar. Re-save your project with some Aerial Imagery.
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Section 7: Adding map features (Digitising)

The easiest way to learn about how to draw features is by doing it for yourself so lets add  
some layers of our own and make a start...

Exercise 7.1 Digitising points from Google Mapping (Individual Trees)

Step 1. Open up a simple project (the one you created in section 5) and create a new 
layer to draw onto as follows:

You will be prompted for a location to save the layer and a layer name.

Step 2. Type in a layer name and tell QGIS whether the layer will contain Points, Lines or 
Polygons (areas). Call the layer “Points” and make sure the Point type is selected.  Make 
sure the projection is British National Grid (EPSG: 27700).

Your new map layer will appear in the layer list on the left side if the screen.

Step 3. Make sure your layer is selected as shown above and ensure that the Digitising 
toolbar is active as shown below.

The yellow pencil button is a toggle which turns
the digitising toolbar on and off.

Step 4. Zoom over a tree on the base mapping and Select the add feature
button and click on the canvas to add points to the map.

Once you have added points, feel free to play around with the properties of the map layer 
as you did in section 3.4. (Hint: either double-click the layer name or right-click and choose
Properties)

Removing a feature
To remove a point choose the select button and select the point you want to 
remove (it becomes highlighted) and finally press the red Delete Selected button 

Repositioning a feature
Features can be moved by using the Move Feature button. Click on the button and 
then on the feature you want to move, dragging it into a new position. 

Step 5. Press the Save Layer Edits button to save all your changes.  If you forget 
to do this with a Memory Layer then QGIS will prompt you to save the changes 
before you exit the program.

Excellent! You have now added some features to the map.
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Map attributes 

An Attribute is the name given to any data that is attached to a mapped feature.

An example of an attribute would be “Owner” in a Land Ownership layer or “TreeType” in 
an Orchards layer.  More than one attribute can be recorded against a mapped feature.

You can add attributes to a layer either when you create it or by right-clicking and choosing
Fields. (QGIS used fields and attributes interchangeably)

Exercise 7.2 Points with attributes

Create a new layer (using the same process as 7.1) and this time we will add a New field

Type “Species” and say it is a Text data type – the length refers to how many characters 
we will need to hold the values, 80 is more than enough.

Press Add to fields list.

Let's add another attribute called “Age_Years” of type Integer and Length 4 (up to 9999!)

Press Add to fields list

Now add a final attribute called “Height_m” of type Decimal Length 10 Precision 1

Upon completion of adding a feature you will be prompted to complete the following form.
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Exercise 7.3 Creating a drop down list to populate attributes

If you have a large data digitising project with lots of attribute information then you can 
define preset lists to choose from which will save you typing and spelling errors– for 
example you may have a list of all English Apple tree varieties.

Choose either to create a New Layer (or modify the one you created in 7.2 above).

Right-Click on the layer name and choose Fields

Press the Text Edit button next
to the attribute you would like
the list to appear and choose
Value Map from the list of
available options on the left.

Put a value in the first column (a sequential number is
fine, this will get stored) and a description in the second
column. 

You will see the descriptions appear when
you add a new feature.

Save your edits , press the information button and click on the feature to review
your work.

If you have time – repeat the processes we have just covered in this section with a 
Polygon or Polyline data set.

Note: Right-click your mouse to finish drawing a polygon. Reshape a polygon by clicking
on the node tool

Congratulations you have now completed your basic introduction to QGIS !
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